cisco router configuration

配置PPPoE拨号连接

上一节中,经过了一番波折我终于成功启动了这台路由器,并制定了用它上网的小目标。这期我就来介绍一下实现这个目标的过程。

为了方便说明,本文设定以下示例条件:

  • 路由器WAN口连接光猫,通过pppoe拨号上网
  • 从运营商获得的用户名为user_id 密码为user_pass
  • 内网配置一个Vlan,网段为192.168.1.0/24
  • Vlan的网关地址为192.168.1.254
  • 将192.168.1.1 到192.168.1.100作为动态分配地址,其余部分留作静态分配
  • 运营商网络的MTU为1454

关于MTU MRU MSS:
通常在Ethernet网络中使用的默认值(也是不使用JumboFrame等扩展标准的最大值)如下:
MTU(Maximum Transmission Unit): 1500byte
MRU(Maximum Receive Unit): 1500byte
MSS(Maximum Segment Size): MTU减去IP报头(20byte),TCP报头(20byte): 1460byte
当我们使用PPPOE拨号连接时,PPPOE报头需要占用8字节,则MTU/MRU最大为1492,mss最大为1452
而实际应用中的数值根据运营商有各有不同,比如日本使用最广泛的Flets网络的MTU设定在1454。

进入配置模式

使用enable命令获得管理权限,然后进入通过控制台配置的模式。
之后出现的router-config#即为配置模式的根目录。本文之后出现的配置都是从根目录开始,最后通过exit返回根目录。

router> enable
router# config terminal
router-config# 

PPPOE拨号虚拟接口

创建dialer1虚拟拨号接口并进入接口配置

interface dialer1  
  mtu 1454
  ip address negotiated
  ip tcp adjust-mss 1414
  ip nat outside
  dialer pool 1
  dialer-group 1
  encapsulation ppp
  ppp authentication chap callin
  ppp chap hostname user_id
  ppp chap password user_pass
  ppp pap sent-username user_id password user_pass
  ppp ipcp dns request accept
  exit

这里有两个很相似的命令:mtuip mtu
ip mtu 是设定这个端口是ip包的mtu,而mtu是设定在这个端口上通过的所有数据包的mtu。因为我们的外网端口是要与运营商网络进行协同,所以使用mtu对所有包的大小进行设置。
关于chap和pap两种认证方式,如果确定自己的运营商使用哪一种方式的话只需要设置对应的认证信息即可。如果不确定就两种都写上。
然后将连接到光猫的网口加入pppoe拨号池

interface GigabitEthernet8
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1
exit

完成后稍等片刻,通过下面的命令显示端口信息:

show interface dialer1

如果看到端口获得了外网ip地址,则表示pppoe拨号连接已成功建立。

配置VLAN

外部网络已经连接上互联网,接下来就要配置内部网络,让我们的设备通过内部LAN连接到外网。
路由器默认会自动生成一个Vlan1,并自动将8个交换口配置在Vlan1内,如果没有特别的需求则直接对Vlan1进行配置即可。

interface Vlan1
  ip address 192.168.1.254 255.255.255.0
  ip nat inside
  no shutdown
  exit  

思科的IOS配置命令中,几乎所有的命令都可以在前面加no来进行取消或执行相反的操作。
因为接口的默认状态是shutdown,所以要通过no shutdown来确保接口进入UP状态

NAT转发规则

与刚才所说接口的默认状态是shutdown同理,企业级路由器处于安全和性能考虑,默认配置遵循“不启用,不连接,不转发”的原则
所以虽然配置了Vlan,但是Vlan和外部端口之间默认是不会进行路由转发的。我们需要手动配置内部转发规则:

ip nat inside source list 1 interface dialer 1 overload
dialer-list 1 protocol ip permit
ip route 0.0.0.0 0.0.0.0 dialer 1 permanent
access-list 1 permit 192.168.1.0 0.0.0.255

因为我们只有一个外网接口,所以直接将所有的地址转发到dialer 1。permanent表示即使dialer1链接中断也永久保留这条转发规则

配置DHCP

PC,NAS,AP等固定设备可以配置成静态IP以便于管理。但是我们还要连接手机等移动设备,并且随着物联网的兴起,一些智能设备也需要HDCP才能完成初始配置,所以从地址池中分配一部分ip作为通过DHCP自动分配还是很有必要的。

ip dhcp pool lan
  network 192.168.1.0 255.255.255.0
  default-router 192.168.1.254
  dns-server 8.8.8.8 8.8.4.4
  exit

ip dhcp excluded-address 192.168.1.101 192.168.1.254

这里需要注意的是dhcp分配范围是设定除外ip,而不是供dhcp分配的ip

至此我们的路由器应该已经可以和一般的家用路由器一样自动拨号上网了。但是当前配置都是保存在系统RAM中的,所以最后不要忘了使用write命令将配置写入NVRAM,否则下次因为断电等原因重启之后所有配置都会消失!(FLAG已立)

Ads